dns2tcp: add package
This commit is contained in:
parent
3fd177086d
commit
788cd61d36
43
dns2tcp/Makefile
Normal file
43
dns2tcp/Makefile
Normal file
@ -0,0 +1,43 @@
|
|||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=dns2tcp
|
||||||
|
PKG_VERSION:=1.1.0
|
||||||
|
PKG_RELEASE:=3
|
||||||
|
|
||||||
|
PKG_SOURCE_PROTO:=git
|
||||||
|
PKG_SOURCE_URL:=https://github.com/zfl9/dns2tcp.git
|
||||||
|
PKG_SOURCE_VERSION:=10ed687778f18d1b9c98bb51187a3a9086d3a0d9
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
||||||
|
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION)
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)/$(PKG_SOURCE_SUBDIR)
|
||||||
|
|
||||||
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
PKG_USE_MIPS16:=0
|
||||||
|
|
||||||
|
PKG_LICENSE:=GPL-3.0
|
||||||
|
PKG_LICENSE_FILES:=LICENSE
|
||||||
|
PKG_MAINTAINER:=pexcn <i@pexcn.me>
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/dns2tcp
|
||||||
|
SECTION:=net
|
||||||
|
CATEGORY:=Network
|
||||||
|
TITLE:=Utility to convert DNS query from UDP to TCP
|
||||||
|
URL:=https://github.com/zfl9/dns2tcp
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/dns2tcp/description
|
||||||
|
Utility to convert DNS query from UDP to TCP.
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/dns2tcp/conffiles
|
||||||
|
/etc/config/dns2tcp
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/dns2tcp/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/dns2tcp $(1)/usr/bin
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,dns2tcp))
|
31
dns2tcp/patches/001-build-with-gcc-O3-optimizations.patch
Normal file
31
dns2tcp/patches/001-build-with-gcc-O3-optimizations.patch
Normal file
@ -0,0 +1,31 @@
|
|||||||
|
From 01fc93331291ea55e8306374f6406c130de951a8 Mon Sep 17 00:00:00 2001
|
||||||
|
From: pexcn <i@pexcn.me>
|
||||||
|
Date: Sun, 5 Apr 2020 22:30:26 +0800
|
||||||
|
Subject: [PATCH] build with gcc -O3 optimizations
|
||||||
|
|
||||||
|
---
|
||||||
|
Makefile | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/Makefile b/Makefile
|
||||||
|
index ae6c171..02b8587 100644
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -1,12 +1,12 @@
|
||||||
|
CC = gcc
|
||||||
|
-CFLAGS = -std=c99 -Wall -Wextra -O2
|
||||||
|
+CFLAGS = -std=c99 -Wall -Wextra -O3
|
||||||
|
LIBS = -lm
|
||||||
|
SRCS = dns2tcp.c
|
||||||
|
OBJS = $(SRCS:.c=.o)
|
||||||
|
MAIN = dns2tcp
|
||||||
|
DESTDIR = /usr/local/bin
|
||||||
|
|
||||||
|
-EVCFLAGS = -w -O2
|
||||||
|
+EVCFLAGS = -w -O3
|
||||||
|
EVSRCFILE = libev/ev.c
|
||||||
|
EVOBJFILE = ev.o
|
||||||
|
|
||||||
|
--
|
||||||
|
2.25.1
|
||||||
|
|
Loading…
Reference in New Issue
Block a user