v2raya: Update to 1.5.9.1698.1
This commit is contained in:
parent
39624b695b
commit
7b679731a5
@ -5,12 +5,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=v2rayA
|
PKG_NAME:=v2rayA
|
||||||
PKG_VERSION:=1.5.8.1
|
PKG_VERSION:=1.5.9.1698.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://codeload.github.com/v2rayA/v2rayA/tar.gz/v$(PKG_VERSION)?
|
PKG_SOURCE_URL:=https://codeload.github.com/v2rayA/v2rayA/tar.gz/v$(PKG_VERSION)?
|
||||||
PKG_HASH:=822ec4a93933d93aed1bda6f9a3c08915135c0fc33bebe5e69b293cf30fe35c2
|
PKG_HASH:=247a357230c616bf48309c61d119686e4ad56939c05afef584c45051e9dc6220
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/service
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/service
|
||||||
|
|
||||||
PKG_LICENSE:=AGPL-3.0-only
|
PKG_LICENSE:=AGPL-3.0-only
|
||||||
@ -61,7 +61,7 @@ define Download/v2raya-web
|
|||||||
URL:=https://codeload.github.com/v2rayA/v2raya-web/tar.gz/v$(PKG_VERSION)?
|
URL:=https://codeload.github.com/v2rayA/v2raya-web/tar.gz/v$(PKG_VERSION)?
|
||||||
URL_FILE:=$(WEB_FILE)
|
URL_FILE:=$(WEB_FILE)
|
||||||
FILE:=$(WEB_FILE)
|
FILE:=$(WEB_FILE)
|
||||||
HASH:=b13beac91d75c64af4ca6d7365716968702ce1be3f0c3e94d26e01daa07f223b
|
HASH:=149097a42c3e5fa6f5c3cd46d1bf7ec4546e79ad37c1446b759539e700bd75e2
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Prepare
|
define Build/Prepare
|
||||||
|
10
v2raya/patches/100-compat-v5.patch
Normal file
10
v2raya/patches/100-compat-v5.patch
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
--- a/core/v2ray/process.go
|
||||||
|
+++ b/core/v2ray/process.go
|
||||||
|
@@ -226,6 +226,7 @@ func StartCoreProcess(ctx context.Contex
|
||||||
|
dir := path.Dir(v2rayBinPath)
|
||||||
|
var arguments = []string{
|
||||||
|
v2rayBinPath,
|
||||||
|
+ "run",
|
||||||
|
"--config=" + asset.GetV2rayConfigPath(),
|
||||||
|
}
|
||||||
|
if confdir := asset.GetV2rayConfigDirPath(); confdir != "" {
|
Loading…
Reference in New Issue
Block a user