luci-app-passwall: sync upstream

last commit: d63eb1bf19
This commit is contained in:
actions 2024-06-21 02:00:06 +08:00
parent 9fa6bd3482
commit 7daf1d5ac2
2 changed files with 7 additions and 5 deletions

View File

@ -21,10 +21,12 @@ function index()
entry({"admin", "services", appname, "reset_config"}, call("reset_config")).leaf = true
entry({"admin", "services", appname, "show"}, call("show_menu")).leaf = true
entry({"admin", "services", appname, "hide"}, call("hide_menu")).leaf = true
if uci:get(appname, "@global[0]", "hide_from_luci") == "1" then
return
local e
if uci:get(appname, "@global[0]", "hide_from_luci") ~= "1" then
e = entry({"admin", "services", appname}, alias("admin", "services", appname, "settings"), _("Pass Wall"), -1)
else
e = entry({"admin", "services", appname}, alias("admin", "services", appname, "settings"), nil, -1)
end
e = entry({"admin", "services", appname}, alias("admin", "services", appname, "settings"), _("Pass Wall"), -1)
e.dependent = true
e.acl_depends = { "luci-app-passwall" }
--[[ Client ]]

View File

@ -11,10 +11,10 @@ index 7543450..6a4ce1e 100644
include $(TOPDIR)/feeds/luci/luci.mk
diff --git a/luci-app-passwall/luasrc/controller/passwall.lua b/luci-app-passwall/luasrc/controller/passwall.lua
index e52338c..7c71fff 100644
index 1440118..be9dd12 100644
--- a/luci-app-passwall/luasrc/controller/passwall.lua
+++ b/luci-app-passwall/luasrc/controller/passwall.lua
@@ -263,7 +263,7 @@ function connect_status()
@@ -265,7 +265,7 @@ function connect_status()
url = "--socks5 127.0.0.1:" .. socks_port .. " " .. url
end
end