parent
3114e52247
commit
83651f92e5
@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
|
|||||||
|
|
||||||
PKG_NAME:=luci-app-passwall
|
PKG_NAME:=luci-app-passwall
|
||||||
PKG_VERSION:=24.11.18
|
PKG_VERSION:=24.11.18
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=3
|
||||||
|
|
||||||
PKG_CONFIG_DEPENDS:= \
|
PKG_CONFIG_DEPENDS:= \
|
||||||
CONFIG_PACKAGE_$(PKG_NAME)_Iptables_Transparent_Proxy \
|
CONFIG_PACKAGE_$(PKG_NAME)_Iptables_Transparent_Proxy \
|
||||||
|
@ -783,13 +783,15 @@ function gen_config(var)
|
|||||||
if #valid_nodes == 0 then return nil end
|
if #valid_nodes == 0 then return nil end
|
||||||
|
|
||||||
-- fallback node
|
-- fallback node
|
||||||
|
local fallback_node_tag = nil
|
||||||
local fallback_node_id = _node.fallback_node
|
local fallback_node_id = _node.fallback_node
|
||||||
if fallback_node_id == "" then fallback_node_id = nil end
|
if fallback_node_id == "" or fallback_node_id == "nil" then fallback_node_id = nil end
|
||||||
if fallback_node_id then
|
if fallback_node_id then
|
||||||
local is_new_node = true
|
local is_new_node = true
|
||||||
for _, outbound in ipairs(outbounds) do
|
for _, outbound in ipairs(outbounds) do
|
||||||
if outbound.tag == fallback_node_id then
|
if outbound.tag:find("^" .. fallback_node_id) == 1 then
|
||||||
is_new_node = false
|
is_new_node = false
|
||||||
|
fallback_node_tag = outbound.tag
|
||||||
break
|
break
|
||||||
end
|
end
|
||||||
end
|
end
|
||||||
@ -800,12 +802,7 @@ function gen_config(var)
|
|||||||
if outbound then
|
if outbound then
|
||||||
outbound.tag = outbound.tag .. ":" .. fallback_node.remarks
|
outbound.tag = outbound.tag .. ":" .. fallback_node.remarks
|
||||||
table.insert(outbounds, outbound)
|
table.insert(outbounds, outbound)
|
||||||
else
|
fallback_node_tag = outbound.tag
|
||||||
fallback_node_id = nil
|
|
||||||
end
|
|
||||||
else
|
|
||||||
if not gen_balancer(fallback_node) then
|
|
||||||
fallback_node_id = nil
|
|
||||||
end
|
end
|
||||||
end
|
end
|
||||||
end
|
end
|
||||||
@ -813,10 +810,10 @@ function gen_config(var)
|
|||||||
table.insert(balancers, {
|
table.insert(balancers, {
|
||||||
tag = balancer_tag,
|
tag = balancer_tag,
|
||||||
selector = valid_nodes,
|
selector = valid_nodes,
|
||||||
fallbackTag = fallback_node_id,
|
fallbackTag = fallback_node_tag,
|
||||||
strategy = { type = _node.balancingStrategy or "random" }
|
strategy = { type = _node.balancingStrategy or "random" }
|
||||||
})
|
})
|
||||||
if _node.balancingStrategy == "leastPing" or fallback_node_id then
|
if _node.balancingStrategy == "leastPing" or fallback_node_tag then
|
||||||
if not observatory then
|
if not observatory then
|
||||||
observatory = {
|
observatory = {
|
||||||
subjectSelector = { "blc-" },
|
subjectSelector = { "blc-" },
|
||||||
@ -1191,13 +1188,8 @@ function gen_config(var)
|
|||||||
|
|
||||||
--[[
|
--[[
|
||||||
local default_dns_flag = "remote"
|
local default_dns_flag = "remote"
|
||||||
if node_id and tcp_redir_port then
|
if (not COMMON.default_balancer_tag and not COMMON.default_outbound_tag) or COMMON.default_outbound_tag == "direct" then
|
||||||
local node = uci:get_all(appname, node_id)
|
default_dns_flag = "direct"
|
||||||
if node.protocol == "_shunt" then
|
|
||||||
if node.default_node == "_direct" then
|
|
||||||
default_dns_flag = "direct"
|
|
||||||
end
|
|
||||||
end
|
|
||||||
end
|
end
|
||||||
|
|
||||||
if dns.servers and #dns.servers > 0 then
|
if dns.servers and #dns.servers > 0 then
|
||||||
|
@ -1,5 +1,5 @@
|
|||||||
diff --git a/luci-app-passwall/Makefile b/luci-app-passwall/Makefile
|
diff --git a/luci-app-passwall/Makefile b/luci-app-passwall/Makefile
|
||||||
index 4a14c50..0a0f58a 100644
|
index eaa3e9b..a730ee9 100644
|
||||||
--- a/luci-app-passwall/Makefile
|
--- a/luci-app-passwall/Makefile
|
||||||
+++ b/luci-app-passwall/Makefile
|
+++ b/luci-app-passwall/Makefile
|
||||||
@@ -171,7 +171,6 @@ define Package/$(PKG_NAME)/conffiles
|
@@ -171,7 +171,6 @@ define Package/$(PKG_NAME)/conffiles
|
||||||
|
Loading…
Reference in New Issue
Block a user