parent
3e8d165b4d
commit
dc771f96df
@ -412,7 +412,9 @@ o.datatype = "uinteger"
|
|||||||
o.default = "30"
|
o.default = "30"
|
||||||
|
|
||||||
o = s:option(Value, "keepaliveperiod", translate("The keep-alive period.(Unit:second)"))
|
o = s:option(Value, "keepaliveperiod", translate("The keep-alive period.(Unit:second)"))
|
||||||
|
o.description = translate("Default value 0 indicatesno heartbeat.")
|
||||||
o:depends({type = "hysteria", flag_quicparam = "1"})
|
o:depends({type = "hysteria", flag_quicparam = "1"})
|
||||||
|
o:depends({type = "v2ray", v2ray_protocol = "wireguard"})
|
||||||
o.rmempty = true
|
o.rmempty = true
|
||||||
o.datatype = "uinteger"
|
o.datatype = "uinteger"
|
||||||
o.default = "10"
|
o.default = "10"
|
||||||
@ -525,9 +527,7 @@ o.default = "3"
|
|||||||
o.rmempty = true
|
o.rmempty = true
|
||||||
|
|
||||||
o = s:option(Value, "timeout", translate("Timeout for establishing a connection to server(second)"))
|
o = s:option(Value, "timeout", translate("Timeout for establishing a connection to server(second)"))
|
||||||
o.description = translate("Default value 0 indicatesno heartbeat.")
|
|
||||||
o:depends("type", "tuic")
|
o:depends("type", "tuic")
|
||||||
o:depends({type = "v2ray", v2ray_protocol = "wireguard"})
|
|
||||||
o.datatype = "uinteger"
|
o.datatype = "uinteger"
|
||||||
o.default = "8"
|
o.default = "8"
|
||||||
o.rmempty = true
|
o.rmempty = true
|
||||||
@ -568,6 +568,7 @@ o.rmempty = true
|
|||||||
|
|
||||||
-- Tuic settings for the local inbound socks5 server
|
-- Tuic settings for the local inbound socks5 server
|
||||||
o = s:option(Flag, "tuic_dual_stack", translate("Dual-stack Listening Socket"))
|
o = s:option(Flag, "tuic_dual_stack", translate("Dual-stack Listening Socket"))
|
||||||
|
o.description = translate("If this option is not set, the socket behavior is platform dependent.")
|
||||||
o:depends("type", "tuic")
|
o:depends("type", "tuic")
|
||||||
o.default = "0"
|
o.default = "0"
|
||||||
o.rmempty = true
|
o.rmempty = true
|
||||||
@ -941,7 +942,8 @@ o:depends("reality", true)
|
|||||||
o.rmempty = true
|
o.rmempty = true
|
||||||
|
|
||||||
o = s:option(DynamicList, "tls_alpn", translate("TLS ALPN"))
|
o = s:option(DynamicList, "tls_alpn", translate("TLS ALPN"))
|
||||||
o:depends({type = "tuic", tls = true})
|
o:depends("type", "tuic")
|
||||||
|
o.default = "h3"
|
||||||
o.rmempty = true
|
o.rmempty = true
|
||||||
|
|
||||||
-- [[ allowInsecure ]]--
|
-- [[ allowInsecure ]]--
|
||||||
|
@ -155,22 +155,22 @@ msgid "Obfuscation Password"
|
|||||||
msgstr "混淆密码"
|
msgstr "混淆密码"
|
||||||
|
|
||||||
msgid "Hysterir QUIC parameters"
|
msgid "Hysterir QUIC parameters"
|
||||||
msgstr "QUIC参数"
|
msgstr "QUIC 参数"
|
||||||
|
|
||||||
msgid "QUIC initStreamReceiveWindow"
|
msgid "QUIC initStreamReceiveWindow"
|
||||||
msgstr "QUIC初始流接收窗口大小。"
|
msgstr "QUIC 初始流接收窗口大小。"
|
||||||
|
|
||||||
msgid "QUIC maxStreamReceiveWindow"
|
msgid "QUIC maxStreamReceiveWindow"
|
||||||
msgstr "QUIC最大的流接收窗口大小"
|
msgstr "QUIC 最大的流接收窗口大小"
|
||||||
|
|
||||||
msgid "QUIC initConnReceiveWindow"
|
msgid "QUIC initConnReceiveWindow"
|
||||||
msgstr "QUIC初始的连接接收窗口大小"
|
msgstr "QUIC 初始的连接接收窗口大小"
|
||||||
|
|
||||||
msgid "QUIC maxConnReceiveWindow"
|
msgid "QUIC maxConnReceiveWindow"
|
||||||
msgstr "QUIC最大的连接接收窗口大小"
|
msgstr "QUIC 最大的连接接收窗口大小"
|
||||||
|
|
||||||
msgid "QUIC maxIdleTimeout(Unit:second)"
|
msgid "QUIC maxIdleTimeout(Unit:second)"
|
||||||
msgstr "QUIC最长空闲超时时间(单位:秒)"
|
msgstr "QUIC 最长空闲超时时间(单位:秒)"
|
||||||
|
|
||||||
msgid "The keep-alive period.(Unit:second)"
|
msgid "The keep-alive period.(Unit:second)"
|
||||||
msgstr "心跳包发送间隔(单位:秒)"
|
msgstr "心跳包发送间隔(单位:秒)"
|
||||||
@ -195,7 +195,7 @@ msgid "Shadow-TLS ChainPoxy type"
|
|||||||
msgstr "代理链类型"
|
msgstr "代理链类型"
|
||||||
|
|
||||||
msgid "Shadowsocks-rust Version"
|
msgid "Shadowsocks-rust Version"
|
||||||
msgstr "shadowsocks rust版本"
|
msgstr "shadowsocks rust 版本"
|
||||||
|
|
||||||
msgid "Vmess Protocol"
|
msgid "Vmess Protocol"
|
||||||
msgstr "VMESS协议"
|
msgstr "VMESS协议"
|
||||||
@ -982,19 +982,19 @@ msgid "Enable Netflix Mode"
|
|||||||
msgstr "启用 Netflix 分流模式"
|
msgstr "启用 Netflix 分流模式"
|
||||||
|
|
||||||
msgid "TUIC User UUID"
|
msgid "TUIC User UUID"
|
||||||
msgstr "TUIC用户uuid"
|
msgstr "TUIC 用户 uuid"
|
||||||
|
|
||||||
msgid "TUIC Server IP Address"
|
msgid "TUIC Server IP Address"
|
||||||
msgstr "TUIC 服务器IP地址"
|
msgstr "TUIC 服务器 IP 地址"
|
||||||
|
|
||||||
msgid "TUIC User Password"
|
msgid "TUIC User Password"
|
||||||
msgstr "TUIC用户密钥"
|
msgstr "TUIC 用户密钥"
|
||||||
|
|
||||||
msgid "UDP relay mode"
|
msgid "UDP relay mode"
|
||||||
msgstr "UDP中继模式"
|
msgstr "UDP 中继模式"
|
||||||
|
|
||||||
msgid "native UDP characteristics"
|
msgid "native UDP characteristics"
|
||||||
msgstr "原生UDP特性"
|
msgstr "原生 UDP 特性"
|
||||||
|
|
||||||
msgid "lossless UDP relay using QUIC streams"
|
msgid "lossless UDP relay using QUIC streams"
|
||||||
msgstr "使用 QUIC 流的无损 UDP 中继"
|
msgstr "使用 QUIC 流的无损 UDP 中继"
|
||||||
@ -1009,13 +1009,13 @@ msgid "Timeout for establishing a connection to server(second)"
|
|||||||
msgstr "连接超时时间(单位:秒)"
|
msgstr "连接超时时间(单位:秒)"
|
||||||
|
|
||||||
msgid "Garbage collection interval(second)"
|
msgid "Garbage collection interval(second)"
|
||||||
msgstr "UDP数据包片残片清理间隔(单位:秒)"
|
msgstr "UDP 数据包片残片清理间隔(单位:秒)"
|
||||||
|
|
||||||
msgid "Garbage collection lifetime(second)"
|
msgid "Garbage collection lifetime(second)"
|
||||||
msgstr "UDP数据包残片在服务器的保留时间(单位:秒)"
|
msgstr "UDP 数据包残片在服务器的保留时间(单位:秒)"
|
||||||
|
|
||||||
msgid "Disable SNI"
|
msgid "Disable SNI"
|
||||||
msgstr "关闭SNI服务器名称指示"
|
msgstr "关闭 SNI 服务器名称指示"
|
||||||
|
|
||||||
msgid "Enable 0-RTT QUIC handshake"
|
msgid "Enable 0-RTT QUIC handshake"
|
||||||
msgstr "客户端启用 0-RTT QUIC 连接握手"
|
msgstr "客户端启用 0-RTT QUIC 连接握手"
|
||||||
@ -1027,10 +1027,13 @@ msgid "TUIC receive window"
|
|||||||
msgstr "接收窗口(无需确认即可接收的最大字节数:默认8Mb)"
|
msgstr "接收窗口(无需确认即可接收的最大字节数:默认8Mb)"
|
||||||
|
|
||||||
msgid "Dual-stack Listening Socket"
|
msgid "Dual-stack Listening Socket"
|
||||||
msgstr "双栈Socket监听"
|
msgstr "双栈 Socket 监听"
|
||||||
|
|
||||||
|
msgid "If this option is not set, the socket behavior is platform dependent."
|
||||||
|
msgstr "如果未设置此选项,则 Socket 行为依赖于平台。"
|
||||||
|
|
||||||
msgid "Maximum packet size the socks5 server can receive from external"
|
msgid "Maximum packet size the socks5 server can receive from external"
|
||||||
msgstr "socks5服务器可以从外部接收的最大数据包大小(单位:字节)"
|
msgstr "socks5 服务器可以从外部接收的最大数据包大小(单位:字节)"
|
||||||
|
|
||||||
msgid "Disable ChinaDNS-NG"
|
msgid "Disable ChinaDNS-NG"
|
||||||
msgstr "直通模式(禁用ChinaDNS-NG)"
|
msgstr "直通模式(禁用 ChinaDNS-NG)"
|
||||||
|
@ -1,10 +1,12 @@
|
|||||||
#!/bin/sh
|
#!/bin/sh
|
||||||
|
|
||||||
uci -q batch <<-EOF >/dev/null
|
uci -q batch <<-EOF >/dev/null
|
||||||
|
[ -e "/etc/config/ucitrack" ] && {
|
||||||
delete ucitrack.@shadowsocksr[-1]
|
delete ucitrack.@shadowsocksr[-1]
|
||||||
add ucitrack shadowsocksr
|
add ucitrack shadowsocksr
|
||||||
set ucitrack.@shadowsocksr[-1].init=shadowsocksr
|
set ucitrack.@shadowsocksr[-1].init=shadowsocksr
|
||||||
commit ucitrack
|
commit ucitrack
|
||||||
|
}
|
||||||
|
|
||||||
delete firewall.shadowsocksr
|
delete firewall.shadowsocksr
|
||||||
set firewall.shadowsocksr=include
|
set firewall.shadowsocksr=include
|
||||||
|
@ -73,7 +73,7 @@ function wireguard()
|
|||||||
publicKey = server.peer_pubkey,
|
publicKey = server.peer_pubkey,
|
||||||
preSharedKey = server.preshared_key,
|
preSharedKey = server.preshared_key,
|
||||||
endpoint = server.server .. ":" .. server.server_port,
|
endpoint = server.server .. ":" .. server.server_port,
|
||||||
keepAlive = tonumber(server.heartbeat),
|
keepAlive = tonumber(server.keepaliveperiod),
|
||||||
allowedIPs = (server.allowedips) or nil,
|
allowedIPs = (server.allowedips) or nil,
|
||||||
}
|
}
|
||||||
},
|
},
|
||||||
@ -476,8 +476,8 @@ local tuic = {
|
|||||||
receive_window = tonumber(server.receive_window)
|
receive_window = tonumber(server.receive_window)
|
||||||
},
|
},
|
||||||
["local"] = {
|
["local"] = {
|
||||||
server = tonumber(socks_port) and (server.tuic_dual_stack == "1" and "[::1]:" or "127.0.0.1:") .. (socks_port == "0" and local_port or tonumber(socks_port)),
|
server = tonumber(socks_port) and "[::]:" .. (socks_port == "0" and local_port or tonumber(socks_port)),
|
||||||
dual_stack = (server.tuic_dual_stack == "1") and true or false,
|
dual_stack = (server.tuic_dual_stack == "1") and true or nil,
|
||||||
max_packet_size = tonumber(server.tuic_max_package_size)
|
max_packet_size = tonumber(server.tuic_max_package_size)
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
@ -0,0 +1,4 @@
|
|||||||
|
{
|
||||||
|
"config": "shadowsocksr",
|
||||||
|
"init": "shadowsocksr"
|
||||||
|
}
|
@ -1,28 +1,3 @@
|
|||||||
From e0f9cf419ee84763792fecf1d8baa5371be068b1 Mon Sep 17 00:00:00 2001
|
|
||||||
From: sbwml <admin@cooluc.com>
|
|
||||||
Date: Tue, 9 Apr 2024 14:48:49 +0800
|
|
||||||
Subject: [PATCH] patch luci-app-ssr-plus
|
|
||||||
|
|
||||||
Signed-off-by: sbwml <admin@cooluc.com>
|
|
||||||
---
|
|
||||||
luci-app-ssr-plus/Makefile | 33 +++--
|
|
||||||
.../luasrc/controller/shadowsocksr.lua | 2 +-
|
|
||||||
.../model/cbi/shadowsocksr/advanced.lua | 39 ------
|
|
||||||
.../luasrc/model/cbi/shadowsocksr/client.lua | 22 +--
|
|
||||||
.../luasrc/model/cbi/shadowsocksr/status.lua | 2 +-
|
|
||||||
.../luasrc/view/shadowsocksr/check.htm | 4 +-
|
|
||||||
.../luasrc/view/shadowsocksr/refresh.htm | 6 +-
|
|
||||||
.../luasrc/view/shadowsocksr/reset.htm | 4 +-
|
|
||||||
.../luasrc/view/shadowsocksr/server_list.htm | 8 +-
|
|
||||||
.../luasrc/view/shadowsocksr/ssrurl.htm | 22 +--
|
|
||||||
luci-app-ssr-plus/po/zh-cn/ssr-plus.po | 21 ---
|
|
||||||
.../root/etc/init.d/shadowsocksr | 131 ++++--------------
|
|
||||||
.../root/etc/ssrplus/mosdns-config.yaml | 43 ------
|
|
||||||
luci-app-ssr-plus/root/etc/ssrplus/white.list | 40 +++++-
|
|
||||||
luci-app-ssr-plus/root/usr/bin/ssr-monitor | 10 --
|
|
||||||
15 files changed, 107 insertions(+), 280 deletions(-)
|
|
||||||
delete mode 100644 luci-app-ssr-plus/root/etc/ssrplus/mosdns-config.yaml
|
|
||||||
|
|
||||||
diff --git a/luci-app-ssr-plus/Makefile b/luci-app-ssr-plus/Makefile
|
diff --git a/luci-app-ssr-plus/Makefile b/luci-app-ssr-plus/Makefile
|
||||||
index 82e06b3..17e6a6b 100644
|
index 82e06b3..17e6a6b 100644
|
||||||
--- a/luci-app-ssr-plus/Makefile
|
--- a/luci-app-ssr-plus/Makefile
|
||||||
@ -455,7 +430,7 @@ index 479d7e2..5eecbee 100644
|
|||||||
}
|
}
|
||||||
}
|
}
|
||||||
diff --git a/luci-app-ssr-plus/po/zh-cn/ssr-plus.po b/luci-app-ssr-plus/po/zh-cn/ssr-plus.po
|
diff --git a/luci-app-ssr-plus/po/zh-cn/ssr-plus.po b/luci-app-ssr-plus/po/zh-cn/ssr-plus.po
|
||||||
index 632b5c9..cba9707 100644
|
index e292f10..07c6dbc 100644
|
||||||
--- a/luci-app-ssr-plus/po/zh-cn/ssr-plus.po
|
--- a/luci-app-ssr-plus/po/zh-cn/ssr-plus.po
|
||||||
+++ b/luci-app-ssr-plus/po/zh-cn/ssr-plus.po
|
+++ b/luci-app-ssr-plus/po/zh-cn/ssr-plus.po
|
||||||
@@ -552,27 +552,6 @@ msgstr "使用 DNS2TCP 查询"
|
@@ -552,27 +552,6 @@ msgstr "使用 DNS2TCP 查询"
|
||||||
@ -875,6 +850,3 @@ index f637d50..fb9ed57 100755
|
|||||||
fi
|
fi
|
||||||
#chinadns-ng
|
#chinadns-ng
|
||||||
if [ "$(uci -q get "dhcp.@dnsmasq[0]._unused_ssrp_changed")" = "1" ]; then
|
if [ "$(uci -q get "dhcp.@dnsmasq[0]._unused_ssrp_changed")" = "1" ]; then
|
||||||
--
|
|
||||||
2.42.0
|
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user