v2raya: drop wrong patches
These patches should not be backported to OpenWrt, otherwise tproxy won't work for devices connected to br-lan (bypassed by the fw rules). We have introduced a new compile-time flag for new version (which is not released yet), but it's unnecessray to backport redudant patches as here is still at the old version. Fixes: #1042 Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
This commit is contained in:
parent
4f08f7de85
commit
df434fb899
@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=v2rayA
|
||||
PKG_VERSION:=1.5.9.1698.1
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/v2rayA/v2rayA/tar.gz/v$(PKG_VERSION)?
|
||||
|
@ -1,46 +0,0 @@
|
||||
From 78336e55a31db578c139a5bb472aa0fc219c169d Mon Sep 17 00:00:00 2001
|
||||
From: Xiaoxu Guo <ftiasch0@gmail.com>
|
||||
Date: Thu, 4 Aug 2022 16:24:04 +0800
|
||||
Subject: [PATCH] fixed for Docker Compose
|
||||
|
||||
---
|
||||
service/core/iptables/tproxy.go | 7 +++++--
|
||||
1 file changed, 5 insertions(+), 2 deletions(-)
|
||||
|
||||
--- a/core/iptables/tproxy.go
|
||||
+++ b/core/iptables/tproxy.go
|
||||
@@ -65,6 +65,7 @@ iptables -w 2 -t mangle -A TP_PRE -p udp
|
||||
|
||||
iptables -w 2 -t mangle -A TP_RULE -j CONNMARK --restore-mark
|
||||
iptables -w 2 -t mangle -A TP_RULE -m mark --mark 0x40/0xc0 -j RETURN
|
||||
+iptables -w 2 -t mangle -A TP_RULE -i br+ -j RETURN
|
||||
iptables -w 2 -t mangle -A TP_RULE -i docker+ -j RETURN
|
||||
iptables -w 2 -t mangle -A TP_RULE -i veth+ -j RETURN
|
||||
`
|
||||
@@ -123,6 +124,8 @@ ip6tables -w 2 -t mangle -A TP_PRE -p ud
|
||||
|
||||
ip6tables -w 2 -t mangle -A TP_RULE -j CONNMARK --restore-mark
|
||||
ip6tables -w 2 -t mangle -A TP_RULE -m mark --mark 0x40/0xc0 -j RETURN
|
||||
+ip6tables -w 2 -t mangle -A TP_RULE -m mark --mark 0x40/0xc0 -j RETURN
|
||||
+ip6tables -w 2 -t mangle -A TP_RULE -i br+ -j RETURN
|
||||
ip6tables -w 2 -t mangle -A TP_RULE -i docker+ -j RETURN
|
||||
ip6tables -w 2 -t mangle -A TP_RULE -i veth+ -j RETURN
|
||||
`
|
||||
@@ -156,7 +159,7 @@ ip6tables -w 2 -t mangle -A TP_MARK -j C
|
||||
|
||||
func (t *tproxy) GetCleanCommands() Setter {
|
||||
commands := `
|
||||
-ip rule del fwmark 0x40/0xc0 table 100
|
||||
+ip rule del fwmark 0x40/0xc0 table 100
|
||||
ip route del local 0.0.0.0/0 dev lo table 100
|
||||
|
||||
iptables -w 2 -t mangle -F TP_OUT
|
||||
@@ -172,7 +175,7 @@ iptables -w 2 -t mangle -X TP_MARK
|
||||
`
|
||||
if IsIPv6Supported() {
|
||||
commands += `
|
||||
-ip -6 rule del fwmark 0x40/0xc0 table 100
|
||||
+ip -6 rule del fwmark 0x40/0xc0 table 100
|
||||
ip -6 route del local ::/0 dev lo table 100
|
||||
|
||||
ip6tables -w 2 -t mangle -F TP_OUT
|
@ -1,37 +0,0 @@
|
||||
From 0db405f50fd652d494f2066fc5e47c41666c96db Mon Sep 17 00:00:00 2001
|
||||
From: Xiaoxu Guo <ftiasch0@gmail.com>
|
||||
Date: Thu, 4 Aug 2022 16:32:42 +0800
|
||||
Subject: [PATCH] cleaned up
|
||||
|
||||
---
|
||||
service/core/iptables/tproxy.go | 5 ++---
|
||||
1 file changed, 2 insertions(+), 3 deletions(-)
|
||||
|
||||
--- a/core/iptables/tproxy.go
|
||||
+++ b/core/iptables/tproxy.go
|
||||
@@ -124,7 +124,6 @@ ip6tables -w 2 -t mangle -A TP_PRE -p ud
|
||||
|
||||
ip6tables -w 2 -t mangle -A TP_RULE -j CONNMARK --restore-mark
|
||||
ip6tables -w 2 -t mangle -A TP_RULE -m mark --mark 0x40/0xc0 -j RETURN
|
||||
-ip6tables -w 2 -t mangle -A TP_RULE -m mark --mark 0x40/0xc0 -j RETURN
|
||||
ip6tables -w 2 -t mangle -A TP_RULE -i br+ -j RETURN
|
||||
ip6tables -w 2 -t mangle -A TP_RULE -i docker+ -j RETURN
|
||||
ip6tables -w 2 -t mangle -A TP_RULE -i veth+ -j RETURN
|
||||
@@ -159,7 +158,7 @@ ip6tables -w 2 -t mangle -A TP_MARK -j C
|
||||
|
||||
func (t *tproxy) GetCleanCommands() Setter {
|
||||
commands := `
|
||||
-ip rule del fwmark 0x40/0xc0 table 100
|
||||
+ip rule del fwmark 0x40/0xc0 table 100
|
||||
ip route del local 0.0.0.0/0 dev lo table 100
|
||||
|
||||
iptables -w 2 -t mangle -F TP_OUT
|
||||
@@ -175,7 +174,7 @@ iptables -w 2 -t mangle -X TP_MARK
|
||||
`
|
||||
if IsIPv6Supported() {
|
||||
commands += `
|
||||
-ip -6 rule del fwmark 0x40/0xc0 table 100
|
||||
+ip -6 rule del fwmark 0x40/0xc0 table 100
|
||||
ip -6 route del local ::/0 dev lo table 100
|
||||
|
||||
ip6tables -w 2 -t mangle -F TP_OUT
|
@ -1,38 +0,0 @@
|
||||
From 4a87a6fc9a17939cc0fc54058b2128b1f688045a Mon Sep 17 00:00:00 2001
|
||||
From: Xiaoxu Guo <ftiasch0@gmail.com>
|
||||
Date: Thu, 4 Aug 2022 22:56:46 +0800
|
||||
Subject: [PATCH] improved
|
||||
|
||||
---
|
||||
service/core/iptables/tproxy.go | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
--- a/core/iptables/tproxy.go
|
||||
+++ b/core/iptables/tproxy.go
|
||||
@@ -16,7 +16,7 @@ var Tproxy tproxy
|
||||
func (t *tproxy) AddIPWhitelist(cidr string) {
|
||||
// avoid duplication
|
||||
t.RemoveIPWhitelist(cidr)
|
||||
- pos := 5
|
||||
+ pos := 6
|
||||
if configure.GetSettingNotNil().AntiPollution != configure.AntipollutionClosed {
|
||||
pos += 3
|
||||
}
|
||||
@@ -65,7 +65,7 @@ iptables -w 2 -t mangle -A TP_PRE -p udp
|
||||
|
||||
iptables -w 2 -t mangle -A TP_RULE -j CONNMARK --restore-mark
|
||||
iptables -w 2 -t mangle -A TP_RULE -m mark --mark 0x40/0xc0 -j RETURN
|
||||
-iptables -w 2 -t mangle -A TP_RULE -i br+ -j RETURN
|
||||
+iptables -w 2 -t mangle -A TP_RULE -i br-+ -j RETURN
|
||||
iptables -w 2 -t mangle -A TP_RULE -i docker+ -j RETURN
|
||||
iptables -w 2 -t mangle -A TP_RULE -i veth+ -j RETURN
|
||||
`
|
||||
@@ -124,7 +124,7 @@ ip6tables -w 2 -t mangle -A TP_PRE -p ud
|
||||
|
||||
ip6tables -w 2 -t mangle -A TP_RULE -j CONNMARK --restore-mark
|
||||
ip6tables -w 2 -t mangle -A TP_RULE -m mark --mark 0x40/0xc0 -j RETURN
|
||||
-ip6tables -w 2 -t mangle -A TP_RULE -i br+ -j RETURN
|
||||
+ip6tables -w 2 -t mangle -A TP_RULE -i br-+ -j RETURN
|
||||
ip6tables -w 2 -t mangle -A TP_RULE -i docker+ -j RETURN
|
||||
ip6tables -w 2 -t mangle -A TP_RULE -i veth+ -j RETURN
|
||||
`
|
@ -13,8 +13,8 @@ Subject: [PATCH] fix: we should skip interface ppp+ to avoid to break net
|
||||
func (t *tproxy) AddIPWhitelist(cidr string) {
|
||||
// avoid duplication
|
||||
t.RemoveIPWhitelist(cidr)
|
||||
- pos := 6
|
||||
+ pos := 8
|
||||
- pos := 5
|
||||
+ pos := 7
|
||||
if configure.GetSettingNotNil().AntiPollution != configure.AntipollutionClosed {
|
||||
pos += 3
|
||||
}
|
||||
|
Loading…
Reference in New Issue
Block a user