164 lines
5.2 KiB
Diff
164 lines
5.2 KiB
Diff
diff --git a/luci-app-passwall/Makefile b/luci-app-passwall/Makefile
|
|
index 18cdd8d..44f5958 100644
|
|
--- a/luci-app-passwall/Makefile
|
|
+++ b/luci-app-passwall/Makefile
|
|
@@ -67,7 +67,7 @@ config PACKAGE_$(PKG_NAME)_Nftables_Transparent_Proxy
|
|
config PACKAGE_$(PKG_NAME)_INCLUDE_Geoview
|
|
bool "Include Geoview"
|
|
select PACKAGE_geoview
|
|
- default y if aarch64||arm||i386||x86_64
|
|
+ default n
|
|
|
|
config PACKAGE_$(PKG_NAME)_INCLUDE_Haproxy
|
|
bool "Include Haproxy"
|
|
@@ -177,7 +177,6 @@ define Package/$(PKG_NAME)/conffiles
|
|
/usr/share/passwall/rules/lanlist_ipv4
|
|
/usr/share/passwall/rules/lanlist_ipv6
|
|
/usr/share/passwall/rules/domains_excluded
|
|
-/www/luci-static/resources/qrcode.min.js
|
|
endef
|
|
|
|
define Package/$(PKG_NAME)/postrm
|
|
diff --git a/luci-app-passwall/luasrc/model/cbi/passwall/client/global.lua b/luci-app-passwall/luasrc/model/cbi/passwall/client/global.lua
|
|
index de67f1c..463bdff 100644
|
|
--- a/luci-app-passwall/luasrc/model/cbi/passwall/client/global.lua
|
|
+++ b/luci-app-passwall/luasrc/model/cbi/passwall/client/global.lua
|
|
@@ -492,6 +492,12 @@ o:value("9.9.9.9", "9.9.9.9 (Quad9)")
|
|
o:value("149.112.112.112", "149.112.112.112 (Quad9)")
|
|
o:value("208.67.220.220", "208.67.220.220 (OpenDNS)")
|
|
o:value("208.67.222.222", "208.67.222.222 (OpenDNS)")
|
|
+if nixio.fs.access("/usr/share/mosdns/mosdns.sh") then
|
|
+ local mosdns_port = string.gsub(luci.sys.exec("uci -q get mosdns.config.listen_port"), "\n", "")
|
|
+ if mosdns_port ~= nil and result ~= "" then
|
|
+ o:value("127.0.0.1:" .. mosdns_port, "127.0.0.1:" .. mosdns_port .. " (MosDNS)")
|
|
+ end
|
|
+end
|
|
o:depends({dns_mode = "dns2socks"})
|
|
o:depends({dns_mode = "tcp"})
|
|
o:depends({dns_mode = "udp"})
|
|
@@ -591,7 +597,7 @@ if api.is_finded("smartdns") then
|
|
end
|
|
|
|
o = s:taboption("DNS", Flag, "dns_redirect", translate("DNS Redirect"), translate("Force special DNS server to need proxy devices."))
|
|
-o.default = "1"
|
|
+o.default = "0"
|
|
o.rmempty = false
|
|
|
|
if (m:get("@global_forwarding[0]", "use_nft") or "0") == "1" then
|
|
diff --git a/luci-app-passwall/luasrc/view/passwall/global/status.htm b/luci-app-passwall/luasrc/view/passwall/global/status.htm
|
|
index eb5527e..133c295 100644
|
|
--- a/luci-app-passwall/luasrc/view/passwall/global/status.htm
|
|
+++ b/luci-app-passwall/luasrc/view/passwall/global/status.htm
|
|
@@ -1,5 +1,11 @@
|
|
<%
|
|
local api = require "luci.passwall.api"
|
|
+local fs = require "nixio.fs"
|
|
+local uci = require 'luci.model.uci'.cursor()
|
|
+local mode = 'normal'
|
|
+if fs.access('/etc/config/argon') then
|
|
+ mode = uci:get_first('argon', 'global', 'mode')
|
|
+end
|
|
-%>
|
|
|
|
<style>
|
|
@@ -53,8 +59,30 @@ https://github.com/pure-css/pure/blob/master/LICENSE.md
|
|
line-height: 1.8em;
|
|
min-height: 48px;
|
|
border-radius: 12.375px;
|
|
+ background-image: linear-gradient(270deg, #dde2ff 0%, #fffeff 100%);
|
|
}
|
|
|
|
+ @media (prefers-color-scheme: dark) {
|
|
+ .block h4 {
|
|
+ background-image: none;
|
|
+ background-color: #2c323c;
|
|
+ }
|
|
+ .block.pure-g {
|
|
+ background: #444950;
|
|
+ box-shadow: unset;
|
|
+ }
|
|
+ }
|
|
+ <% if mode == 'dark' then %>
|
|
+ .block h4 {
|
|
+ background-image: none;
|
|
+ background-color: #2c323c;
|
|
+ }
|
|
+ .block.pure-g {
|
|
+ background: #444950;
|
|
+ box-shadow: unset;
|
|
+ }
|
|
+ <% end -%>
|
|
+
|
|
.check {
|
|
cursor: pointer;
|
|
}
|
|
diff --git a/luci-app-passwall/root/usr/share/passwall/0_default_config b/luci-app-passwall/root/usr/share/passwall/0_default_config
|
|
index acacfed..427dc3a 100644
|
|
--- a/luci-app-passwall/root/usr/share/passwall/0_default_config
|
|
+++ b/luci-app-passwall/root/usr/share/passwall/0_default_config
|
|
@@ -32,7 +32,7 @@ config global_haproxy
|
|
|
|
config global_delay
|
|
option start_daemon '1'
|
|
- option start_delay '60'
|
|
+ option start_delay '15'
|
|
|
|
config global_forwarding
|
|
option tcp_no_redir_ports 'disable'
|
|
diff --git a/luci-app-passwall/root/usr/share/passwall/rules/direct_host b/luci-app-passwall/root/usr/share/passwall/rules/direct_host
|
|
index a3b1464..ae67f3b 100644
|
|
--- a/luci-app-passwall/root/usr/share/passwall/rules/direct_host
|
|
+++ b/luci-app-passwall/root/usr/share/passwall/rules/direct_host
|
|
@@ -6,6 +6,13 @@ douyucdn.cn
|
|
douyucdn2.cn
|
|
location.services.mozilla.com
|
|
|
|
+# google
|
|
+dl.google.com
|
|
+
|
|
+# github proxy
|
|
+gh-proxy.com
|
|
+gitmirror.com
|
|
+
|
|
#steam
|
|
steamcontent.com
|
|
dl.steam.clngaa.com
|
|
@@ -19,6 +26,15 @@ cdn-qc.content.steamchina.com
|
|
cdn-ali.content.steamchina.com
|
|
epicgames-download1-1251447533.file.myqcloud.com
|
|
|
|
+# Synology ddns
|
|
+account.synology.com
|
|
+checkip.dyndns.org
|
|
+checkip.synology.com
|
|
+checkipv6.dyndns.org
|
|
+checkipv6.synology.com
|
|
+checkport.synology.com
|
|
+ddns.synology.com
|
|
+
|
|
#DoT/DoH
|
|
dns.alidns.com
|
|
doh.pub
|
|
diff --git a/luci-app-passwall/root/usr/share/passwall/rules/direct_ip b/luci-app-passwall/root/usr/share/passwall/rules/direct_ip
|
|
index b73edaa..ada52ad 100644
|
|
--- a/luci-app-passwall/root/usr/share/passwall/rules/direct_ip
|
|
+++ b/luci-app-passwall/root/usr/share/passwall/rules/direct_ip
|
|
@@ -8,3 +8,7 @@
|
|
120.53.53.53
|
|
180.184.1.1
|
|
180.184.2.2
|
|
+203.208.39.192/28
|
|
+203.208.40.0/23
|
|
+34.149.0.0/16
|
|
+72.18.83.0/24
|
|
diff --git a/luci-app-passwall/root/usr/share/passwall/rules/proxy_host b/luci-app-passwall/root/usr/share/passwall/rules/proxy_host
|
|
index 72c498c..4aa1a8c 100644
|
|
--- a/luci-app-passwall/root/usr/share/passwall/rules/proxy_host
|
|
+++ b/luci-app-passwall/root/usr/share/passwall/rules/proxy_host
|
|
@@ -9,5 +9,4 @@ googleapis.cn
|
|
googleapis.com
|
|
google.com.tw
|
|
google.com.hk
|
|
-gstatic.com
|
|
xn--ngstr-lra8j.com
|