361 lines
16 KiB
Diff
361 lines
16 KiB
Diff
diff --git a/luci-app-passwall/Makefile b/luci-app-passwall/Makefile
|
||
index 2b72468..15c6437 100644
|
||
--- a/luci-app-passwall/Makefile
|
||
+++ b/luci-app-passwall/Makefile
|
||
@@ -144,7 +144,7 @@ config PACKAGE_$(PKG_NAME)_INCLUDE_V2ray_Geodata
|
||
config PACKAGE_$(PKG_NAME)_INCLUDE_V2ray_Geoview
|
||
bool "Include V2ray_Geoview"
|
||
select PACKAGE_geoview
|
||
- default y if aarch64||arm||i386||x86_64
|
||
+ default n
|
||
|
||
config PACKAGE_$(PKG_NAME)_INCLUDE_V2ray_Plugin
|
||
bool "Include V2ray-Plugin (Shadowsocks Plugin)"
|
||
@@ -177,7 +177,6 @@ define Package/$(PKG_NAME)/conffiles
|
||
/usr/share/passwall/rules/lanlist_ipv4
|
||
/usr/share/passwall/rules/lanlist_ipv6
|
||
/usr/share/passwall/rules/domains_excluded
|
||
-/www/luci-static/resources/qrcode.min.js
|
||
endef
|
||
|
||
define Package/$(PKG_NAME)/postrm
|
||
diff --git a/luci-app-passwall/luasrc/controller/passwall.lua b/luci-app-passwall/luasrc/controller/passwall.lua
|
||
index 6851861..669a612 100644
|
||
--- a/luci-app-passwall/luasrc/controller/passwall.lua
|
||
+++ b/luci-app-passwall/luasrc/controller/passwall.lua
|
||
@@ -279,7 +279,7 @@ function connect_status()
|
||
url = "-x socks5h://" .. socks_server .. " " .. url
|
||
end
|
||
end
|
||
- local result = luci.sys.exec('curl --connect-timeout 3 -o /dev/null -I -sk -w "%{http_code}:%{time_appconnect}" ' .. url)
|
||
+ local result = luci.sys.exec('curl --connect-timeout 3 -o /dev/null -I -sk -w "%{http_code}:%{time_starttransfer}" ' .. url)
|
||
local code = tonumber(luci.sys.exec("echo -n '" .. result .. "' | awk -F ':' '{print $1}'") or "0")
|
||
if code ~= 0 then
|
||
local use_time = luci.sys.exec("echo -n '" .. result .. "' | awk -F ':' '{print $2}'")
|
||
diff --git a/luci-app-passwall/luasrc/model/cbi/passwall/client/global.lua b/luci-app-passwall/luasrc/model/cbi/passwall/client/global.lua
|
||
index 958ff0a..89543b9 100644
|
||
--- a/luci-app-passwall/luasrc/model/cbi/passwall/client/global.lua
|
||
+++ b/luci-app-passwall/luasrc/model/cbi/passwall/client/global.lua
|
||
@@ -474,6 +474,12 @@ o:value("9.9.9.9", "9.9.9.9 (Quad9)")
|
||
o:value("149.112.112.112", "149.112.112.112 (Quad9)")
|
||
o:value("208.67.220.220", "208.67.220.220 (OpenDNS)")
|
||
o:value("208.67.222.222", "208.67.222.222 (OpenDNS)")
|
||
+if nixio.fs.access("/usr/share/mosdns/mosdns.sh") then
|
||
+ local mosdns_port = string.gsub(luci.sys.exec("uci -q get mosdns.config.listen_port"), "\n", "")
|
||
+ if mosdns_port ~= nil and result ~= "" then
|
||
+ o:value("127.0.0.1:" .. mosdns_port, "127.0.0.1:" .. mosdns_port .. " (MosDNS)")
|
||
+ end
|
||
+end
|
||
o:depends({dns_mode = "dns2socks"})
|
||
o:depends({dns_mode = "tcp"})
|
||
o:depends({dns_mode = "udp"})
|
||
@@ -565,7 +571,7 @@ if api.is_finded("smartdns") then
|
||
end
|
||
|
||
o = s:taboption("DNS", Flag, "dns_redirect", translate("DNS Redirect"), translate("Force special DNS server to need proxy devices."))
|
||
-o.default = "1"
|
||
+o.default = "0"
|
||
o.rmempty = false
|
||
|
||
if (uci:get(appname, "@global_forwarding[0]", "use_nft") or "0") == "1" then
|
||
diff --git a/luci-app-passwall/luasrc/passwall/api.lua b/luci-app-passwall/luasrc/passwall/api.lua
|
||
index 8c4e6ef..81089eb 100644
|
||
--- a/luci-app-passwall/luasrc/passwall/api.lua
|
||
+++ b/luci-app-passwall/luasrc/passwall/api.lua
|
||
@@ -219,14 +219,7 @@ end
|
||
|
||
function is_install(package)
|
||
if package and #package > 0 then
|
||
- local file_path = "/usr/lib/opkg/info"
|
||
- local file_ext = ".control"
|
||
- local has = sys.call("[ -d " .. file_path .. " ]")
|
||
- if has == 0 then
|
||
- file_path = "/lib/apk/packages"
|
||
- file_ext = ".list"
|
||
- end
|
||
- return sys.call(string.format('[ -s "%s/%s%s" ]', file_path, package, file_ext)) == 0
|
||
+ return sys.call(string.format('opkg list-installed | grep "%s" > /dev/null 2>&1', package)) == 0
|
||
end
|
||
return false
|
||
end
|
||
diff --git a/luci-app-passwall/luasrc/view/passwall/global/status.htm b/luci-app-passwall/luasrc/view/passwall/global/status.htm
|
||
index e8d76ec..a872950 100644
|
||
--- a/luci-app-passwall/luasrc/view/passwall/global/status.htm
|
||
+++ b/luci-app-passwall/luasrc/view/passwall/global/status.htm
|
||
@@ -1,5 +1,11 @@
|
||
<%
|
||
local api = require "luci.passwall.api"
|
||
+local fs = require "nixio.fs"
|
||
+local uci = require 'luci.model.uci'.cursor()
|
||
+local mode = 'normal'
|
||
+if fs.access('/etc/config/argon') then
|
||
+ mode = uci:get_first('argon', 'global', 'mode')
|
||
+end
|
||
-%>
|
||
|
||
<style>
|
||
@@ -53,8 +59,30 @@ https://github.com/pure-css/pure/blob/master/LICENSE.md
|
||
line-height: 1.8em;
|
||
min-height: 48px;
|
||
border-radius: 12.375px;
|
||
+ background-image: linear-gradient(270deg, #dde2ff 0%, #fffeff 100%);
|
||
}
|
||
|
||
+ @media (prefers-color-scheme: dark) {
|
||
+ .block h4 {
|
||
+ background-image: none;
|
||
+ background-color: #2c323c;
|
||
+ }
|
||
+ .block.pure-g {
|
||
+ background: #444950;
|
||
+ box-shadow: unset;
|
||
+ }
|
||
+ }
|
||
+ <% if mode == 'dark' then %>
|
||
+ .block h4 {
|
||
+ background-image: none;
|
||
+ background-color: #2c323c;
|
||
+ }
|
||
+ .block.pure-g {
|
||
+ background: #444950;
|
||
+ box-shadow: unset;
|
||
+ }
|
||
+ <% end -%>
|
||
+
|
||
.check {
|
||
cursor: pointer;
|
||
}
|
||
@@ -138,7 +166,7 @@ https://github.com/pure-css/pure/blob/master/LICENSE.md
|
||
</div>
|
||
</div>
|
||
</div>
|
||
- <div class="pure-u-1-4 check" onclick="check_connect('baidu', 'https://www.baidu.com')">
|
||
+ <div class="pure-u-1-4 check" onclick="check_connect('baidu', 'http://www.baidu.com')">
|
||
<div class="block pure-g">
|
||
<div class="pure-u-1-3">
|
||
<div class="img-con">
|
||
@@ -150,7 +178,7 @@ https://github.com/pure-css/pure/blob/master/LICENSE.md
|
||
</div>
|
||
</div>
|
||
</div>
|
||
- <div class="pure-u-1-4 check" onclick="check_connect('google', 'https://www.google.com/generate_204')">
|
||
+ <div class="pure-u-1-4 check" onclick="check_connect('google', 'http://www.google.com/generate_204')">
|
||
<div class="block pure-g">
|
||
<div class="pure-u-1-3">
|
||
<div class="img-con">
|
||
@@ -162,7 +190,7 @@ https://github.com/pure-css/pure/blob/master/LICENSE.md
|
||
</div>
|
||
</div>
|
||
</div>
|
||
- <div class="pure-u-1-4 check" onclick="check_connect('github', 'https://github.com')">
|
||
+ <div class="pure-u-1-4 check" onclick="check_connect('github', 'http://github.com')">
|
||
<div class="block pure-g">
|
||
<div class="pure-u-1-3">
|
||
<div class="img-con">
|
||
@@ -174,7 +202,7 @@ https://github.com/pure-css/pure/blob/master/LICENSE.md
|
||
</div>
|
||
</div>
|
||
</div>
|
||
- <div class="pure-u-1-4 check" onclick="check_connect('instagram', 'https://www.instagram.com')">
|
||
+ <div class="pure-u-1-4 check" onclick="check_connect('instagram', 'http://www.instagram.com')">
|
||
<div class="block pure-g">
|
||
<div class="pure-u-1-3">
|
||
<div class="img-con">
|
||
diff --git a/luci-app-passwall/root/usr/share/passwall/0_default_config b/luci-app-passwall/root/usr/share/passwall/0_default_config
|
||
index 551c824..2a6a814 100644
|
||
--- a/luci-app-passwall/root/usr/share/passwall/0_default_config
|
||
+++ b/luci-app-passwall/root/usr/share/passwall/0_default_config
|
||
@@ -31,7 +31,7 @@ config global_haproxy
|
||
|
||
config global_delay
|
||
option start_daemon '1'
|
||
- option start_delay '60'
|
||
+ option start_delay '15'
|
||
|
||
config global_forwarding
|
||
option tcp_no_redir_ports 'disable'
|
||
diff --git a/luci-app-passwall/root/usr/share/passwall/app.sh b/luci-app-passwall/root/usr/share/passwall/app.sh
|
||
index 57f52f0..14aa4e4 100755
|
||
--- a/luci-app-passwall/root/usr/share/passwall/app.sh
|
||
+++ b/luci-app-passwall/root/usr/share/passwall/app.sh
|
||
@@ -1589,9 +1589,7 @@ start_dns() {
|
||
[ "$(expr $dnsmasq_version \>= 2.87)" == 0 ] && echolog "Dnsmasq版本低于2.87,有可能无法正常使用!!!"
|
||
}
|
||
|
||
- local DNSMASQ_TUN_DNS=$(get_first_dns TUN_DNS 53 | sed 's/:/#/g')
|
||
local RUN_NEW_DNSMASQ=1
|
||
- RUN_NEW_DNSMASQ=${DNS_REDIRECT}
|
||
if [ "${RUN_NEW_DNSMASQ}" == "0" ]; then
|
||
#The old logic will be removed in the future.
|
||
#Run a copy dnsmasq instance, DNS hijack that don't need a proxy devices.
|
||
@@ -1607,7 +1605,7 @@ start_dns() {
|
||
#Modify the default dnsmasq service
|
||
lua $APP_PATH/helper_dnsmasq.lua stretch
|
||
lua $APP_PATH/helper_dnsmasq.lua add_rule -FLAG "default" -TMP_DNSMASQ_PATH ${GLOBAL_DNSMASQ_CONF_PATH} -DNSMASQ_CONF_FILE ${GLOBAL_DNSMASQ_CONF} \
|
||
- -DEFAULT_DNS ${DEFAULT_DNS} -LOCAL_DNS ${LOCAL_DNS} -TUN_DNS ${DNSMASQ_TUN_DNS} \
|
||
+ -DEFAULT_DNS ${DEFAULT_DNS} -LOCAL_DNS ${LOCAL_DNS} -TUN_DNS ${TUN_DNS} \
|
||
-REMOTE_FAKEDNS ${fakedns:-0} -USE_DEFAULT_DNS "${USE_DEFAULT_DNS:-direct}" -CHINADNS_DNS ${china_ng_listen:-0} \
|
||
-USE_DIRECT_LIST "${USE_DIRECT_LIST}" -USE_PROXY_LIST "${USE_PROXY_LIST}" -USE_BLOCK_LIST "${USE_BLOCK_LIST}" -USE_GFW_LIST "${USE_GFW_LIST}" -CHN_LIST "${CHN_LIST}" \
|
||
-TCP_NODE ${TCP_NODE} -DEFAULT_PROXY_MODE ${TCP_PROXY_MODE} -NO_PROXY_IPV6 ${DNSMASQ_FILTER_PROXY_IPV6:-0} -NFTFLAG ${nftflag:-0} \
|
||
@@ -1619,7 +1617,7 @@ start_dns() {
|
||
GLOBAL_DNSMASQ_CONF=${GLOBAL_ACL_PATH}/dnsmasq.conf
|
||
GLOBAL_DNSMASQ_CONF_PATH=${GLOBAL_ACL_PATH}/dnsmasq.d
|
||
lua $APP_PATH/helper_dnsmasq.lua add_rule -FLAG "default" -TMP_DNSMASQ_PATH ${GLOBAL_DNSMASQ_CONF_PATH} -DNSMASQ_CONF_FILE ${GLOBAL_DNSMASQ_CONF} \
|
||
- -LISTEN_PORT ${GLOBAL_DNSMASQ_PORT} -DEFAULT_DNS ${DEFAULT_DNS} -LOCAL_DNS ${LOCAL_DNS} -TUN_DNS ${DNSMASQ_TUN_DNS} \
|
||
+ -LISTEN_PORT ${GLOBAL_DNSMASQ_PORT} -DEFAULT_DNS ${DEFAULT_DNS} -LOCAL_DNS ${LOCAL_DNS} -TUN_DNS ${TUN_DNS} \
|
||
-REMOTE_FAKEDNS ${fakedns:-0} -USE_DEFAULT_DNS "${USE_DEFAULT_DNS:-direct}" -CHINADNS_DNS ${china_ng_listen:-0} \
|
||
-USE_DIRECT_LIST "${USE_DIRECT_LIST}" -USE_PROXY_LIST "${USE_PROXY_LIST}" -USE_BLOCK_LIST "${USE_BLOCK_LIST}" -USE_GFW_LIST "${USE_GFW_LIST}" -CHN_LIST "${CHN_LIST}" \
|
||
-TCP_NODE ${TCP_NODE} -DEFAULT_PROXY_MODE ${TCP_PROXY_MODE} -NO_PROXY_IPV6 ${DNSMASQ_FILTER_PROXY_IPV6:-0} -NFTFLAG ${nftflag:-0} \
|
||
@@ -1686,7 +1684,8 @@ acl_app() {
|
||
socks_port=11100
|
||
redir_port=11200
|
||
dns_port=11300
|
||
- dnsmasq_port=${GLOBAL_DNSMASQ_PORT:-11400}
|
||
+ dnsmasq_port=11400
|
||
+ [ -n "${GLOBAL_DNSMASQ_PORT}" ] && dnsmasq_port=$(get_new_port $GLOBAL_DNSMASQ_PORT)
|
||
chinadns_port=11500
|
||
for item in $items; do
|
||
sid=$(uci -q show "${CONFIG}.${item}" | grep "=acl_rule" | awk -F '=' '{print $1}' | awk -F '.' '{print $2}')
|
||
@@ -1750,6 +1749,7 @@ acl_app() {
|
||
|
||
[ -n "$tcp_node" ] && {
|
||
local GLOBAL_TCP_NODE=$(get_cache_var "ACL_GLOBAL_TCP_node")
|
||
+ echolog "${GLOBAL_TCP_NODE}"
|
||
[ -n "${GLOBAL_TCP_NODE}" ] && GLOBAL_TCP_redir_port=$(get_cache_var "ACL_GLOBAL_TCP_redir_port")
|
||
if [ "$tcp_node" = "default" ]; then
|
||
if [ -n "${GLOBAL_TCP_NODE}" ]; then
|
||
@@ -2001,10 +2001,8 @@ start() {
|
||
|
||
if [ "$ENABLED_DEFAULT_ACL" == 1 ] || [ "$ENABLED_ACLS" == 1 ]; then
|
||
[ "$(uci -q get dhcp.@dnsmasq[0].dns_redirect)" == "1" ] && {
|
||
- uci -q set ${CONFIG}.@global[0].dnsmasq_dns_redirect='1'
|
||
- uci -q commit ${CONFIG}
|
||
- uci -q set dhcp.@dnsmasq[0].dns_redirect='0'
|
||
- uci -q commit dhcp
|
||
+ uci -q set dhcp.@dnsmasq[0].dns_redirect='0' 2>/dev/null
|
||
+ uci commit dhcp 2>/dev/null
|
||
/etc/init.d/dnsmasq restart >/dev/null 2>&1
|
||
}
|
||
fi
|
||
@@ -2047,23 +2045,11 @@ stop() {
|
||
source $APP_PATH/helper_smartdns.sh del
|
||
rm -rf $GLOBAL_DNSMASQ_CONF
|
||
rm -rf $GLOBAL_DNSMASQ_CONF_PATH
|
||
- [ "1" = "1" ] && {
|
||
- #restore logic
|
||
- bak_dnsmasq_dns_redirect=$(config_t_get global dnsmasq_dns_redirect)
|
||
- [ -n "${bak_dnsmasq_dns_redirect}" ] && {
|
||
- uci -q set dhcp.@dnsmasq[0].dns_redirect="${bak_dnsmasq_dns_redirect}"
|
||
- uci -q commit dhcp
|
||
- uci -q delete ${CONFIG}.@global[0].dnsmasq_dns_redirect
|
||
- uci -q commit ${CONFIG}
|
||
- }
|
||
- if [ -z "$(get_cache_var "ACL_default_dns_port")" ] || [ -n "${bak_dnsmasq_dns_redirect}" ]; then
|
||
- lua $APP_PATH/helper_dnsmasq.lua restart -LOG 0
|
||
- fi
|
||
- bak_bridge_nf_ipt=$(get_cache_var "bak_bridge_nf_ipt")
|
||
- [ -n "${bak_bridge_nf_ipt}" ] && sysctl -w net.bridge.bridge-nf-call-iptables=${bak_bridge_nf_ipt} >/dev/null 2>&1
|
||
- bak_bridge_nf_ip6t=$(get_cache_var "bak_bridge_nf_ip6t")
|
||
- [ -n "${bak_bridge_nf_ip6t}" ] && sysctl -w net.bridge.bridge-nf-call-ip6tables=${bak_bridge_nf_ip6t} >/dev/null 2>&1
|
||
- }
|
||
+ [ -z "$(get_cache_var "ACL_default_dns_port")" ] && lua $APP_PATH/helper_dnsmasq.lua restart -LOG 0
|
||
+ bak_bridge_nf_ipt=$(get_cache_var "bak_bridge_nf_ipt")
|
||
+ [ -n "${bak_bridge_nf_ipt}" ] && sysctl -w net.bridge.bridge-nf-call-iptables=${bak_bridge_nf_ipt} >/dev/null 2>&1
|
||
+ bak_bridge_nf_ip6t=$(get_cache_var "bak_bridge_nf_ip6t")
|
||
+ [ -n "${bak_bridge_nf_ip6t}" ] && sysctl -w net.bridge.bridge-nf-call-ip6tables=${bak_bridge_nf_ip6t} >/dev/null 2>&1
|
||
rm -rf $TMP_PATH
|
||
rm -rf /tmp/lock/${CONFIG}_socks_auto_switch*
|
||
echolog "清空并关闭相关程序和缓存完成。"
|
||
@@ -2122,7 +2108,6 @@ DNS_CACHE=0
|
||
REMOTE_DNS=$(config_t_get global remote_dns 1.1.1.1:53 | sed 's/#/:/g' | sed -E 's/\:([^:]+)$/#\1/g')
|
||
USE_DEFAULT_DNS=$(config_t_get global use_default_dns direct)
|
||
FILTER_PROXY_IPV6=$(config_t_get global filter_proxy_ipv6 0)
|
||
-DNS_REDIRECT=$(config_t_get global dns_redirect 1)
|
||
dns_listen_port=${DNS_PORT}
|
||
|
||
REDIRECT_LIST="socks ss ss-rust ssr sing-box xray trojan-plus naiveproxy hysteria2"
|
||
diff --git a/luci-app-passwall/root/usr/share/passwall/iptables.sh b/luci-app-passwall/root/usr/share/passwall/iptables.sh
|
||
index a1e44f2..c5d23ba 100755
|
||
--- a/luci-app-passwall/root/usr/share/passwall/iptables.sh
|
||
+++ b/luci-app-passwall/root/usr/share/passwall/iptables.sh
|
||
@@ -329,7 +329,6 @@ load_acl() {
|
||
$ip6t_n -A PSW_DNS $(comment "$remarks") -p udp ${_ipt_source} --dport 53 -j REDIRECT --to-ports ${dns_redirect} 2>/dev/null
|
||
$ipt_n -A PSW_DNS $(comment "$remarks") -p tcp ${_ipt_source} --dport 53 -j REDIRECT --to-ports ${dns_redirect}
|
||
$ip6t_n -A PSW_DNS $(comment "$remarks") -p tcp ${_ipt_source} --dport 53 -j REDIRECT --to-ports ${dns_redirect} 2>/dev/null
|
||
- [ -z "$(get_cache_var "ACL_${sid}_tcp_default")" ] && echolog " - ${msg}使用与全局配置不相同节点,已将DNS强制重定向到专用 DNS 服务器。"
|
||
fi
|
||
|
||
[ -n "$tcp_port" -o -n "$udp_port" ] && {
|
||
diff --git a/luci-app-passwall/root/usr/share/passwall/nftables.sh b/luci-app-passwall/root/usr/share/passwall/nftables.sh
|
||
index 3bd9dd0..4cf6f6e 100755
|
||
--- a/luci-app-passwall/root/usr/share/passwall/nftables.sh
|
||
+++ b/luci-app-passwall/root/usr/share/passwall/nftables.sh
|
||
@@ -379,7 +379,6 @@ load_acl() {
|
||
nft "add rule $NFTABLE_NAME PSW_DNS ip protocol tcp ${_ipt_source} tcp dport 53 counter redirect to :${dns_redirect} comment \"$remarks\""
|
||
nft "add rule $NFTABLE_NAME PSW_DNS meta l4proto udp ${_ipt_source} udp dport 53 counter redirect to :${dns_redirect} comment \"$remarks\""
|
||
nft "add rule $NFTABLE_NAME PSW_DNS meta l4proto tcp ${_ipt_source} tcp dport 53 counter redirect to :${dns_redirect} comment \"$remarks\""
|
||
- [ -z "$(get_cache_var "ACL_${sid}_tcp_default")" ] && echolog " - ${msg}使用与全局配置不相同节点,已将DNS强制重定向到专用 DNS 服务器。"
|
||
fi
|
||
|
||
[ -n "$tcp_port" -o -n "$udp_port" ] && {
|
||
diff --git a/luci-app-passwall/root/usr/share/passwall/rules/direct_host b/luci-app-passwall/root/usr/share/passwall/rules/direct_host
|
||
index a3b1464..90bcf58 100644
|
||
--- a/luci-app-passwall/root/usr/share/passwall/rules/direct_host
|
||
+++ b/luci-app-passwall/root/usr/share/passwall/rules/direct_host
|
||
@@ -4,8 +4,13 @@ microsoft.com
|
||
dyndns.com
|
||
douyucdn.cn
|
||
douyucdn2.cn
|
||
+ghgo.xyz
|
||
+gitmirror.com
|
||
location.services.mozilla.com
|
||
|
||
+# google
|
||
+dl.google.com
|
||
+
|
||
#steam
|
||
steamcontent.com
|
||
dl.steam.clngaa.com
|
||
@@ -19,6 +24,15 @@ cdn-qc.content.steamchina.com
|
||
cdn-ali.content.steamchina.com
|
||
epicgames-download1-1251447533.file.myqcloud.com
|
||
|
||
+# Synology ddns
|
||
+account.synology.com
|
||
+checkip.dyndns.org
|
||
+checkip.synology.com
|
||
+checkipv6.dyndns.org
|
||
+checkipv6.synology.com
|
||
+checkport.synology.com
|
||
+ddns.synology.com
|
||
+
|
||
#DoT/DoH
|
||
dns.alidns.com
|
||
doh.pub
|
||
diff --git a/luci-app-passwall/root/usr/share/passwall/rules/direct_ip b/luci-app-passwall/root/usr/share/passwall/rules/direct_ip
|
||
index b73edaa..d48bc4a 100644
|
||
--- a/luci-app-passwall/root/usr/share/passwall/rules/direct_ip
|
||
+++ b/luci-app-passwall/root/usr/share/passwall/rules/direct_ip
|
||
@@ -4,7 +4,11 @@
|
||
223.6.6.6
|
||
119.29.29.29
|
||
180.76.76.76
|
||
+34.149.0.0/16
|
||
+72.18.83.0/24
|
||
1.12.12.12
|
||
120.53.53.53
|
||
+203.208.39.192/28
|
||
+203.208.40.0/23
|
||
180.184.1.1
|
||
180.184.2.2
|
||
diff --git a/luci-app-passwall/root/usr/share/passwall/rules/proxy_host b/luci-app-passwall/root/usr/share/passwall/rules/proxy_host
|
||
index 72c498c..4aa1a8c 100644
|
||
--- a/luci-app-passwall/root/usr/share/passwall/rules/proxy_host
|
||
+++ b/luci-app-passwall/root/usr/share/passwall/rules/proxy_host
|
||
@@ -9,5 +9,4 @@ googleapis.cn
|
||
googleapis.com
|
||
google.com.tw
|
||
google.com.hk
|
||
-gstatic.com
|
||
xn--ngstr-lra8j.com
|